VxRail First Impressions, Installation, Configuration (part 1)

ShareIT

Hyperconverged infrastructure (HCI) is the cool kid of the block at the moment, and proof of this is that big name companies like Cisco and EMC/VCE have recently announced their own solutions in this space to compete with market leader Nutanix.

This should not be a surprise for anyone because according to IDC, HCI systems are forecasted to be a $3.9B market but 2019, which is an incredible growth when compared to $0.8B in 2015. Not only the expected growth is exceptional, but this growth is also taking a big piece of the cake on the traditional enterprise storage market, so companies like EMC and Cisco need secure this revenue stream.

In this first blog post I will be describing my VCE VxRail first impressions on the hardware installation and configuration. The second part will be dedicated to management and different features that are available on web interface. The official release date of VxRail is 3/10/2016 but I had the opportunity to install an evaluation unit. Before I start, I want to thank my employer RoundTower Technologies for giving me sometime to play with the evaluation unit was sent to us.

The Hardware

Lets start describing what we received. Our eval unit is a four node VxRail 160, more information about the offerings can be found here. The system is based on Quanta servers as your can see on the pictures below.

Front

IMG_0549

Back

IMG_0550

Inside

IMG_0551

Each node in this appliance has the following components:

  • 256GB of RAM
  • Two (2) x Intel Xeon Processor E5-2630, with 8 cores for a total of 16 cores per node, hence the name VxRail 160
  • One (1) x 800GB SSD
  • Five (5) x 1.2TB HDD – 10k rpm
  • Two (2) x 10GE SFP+
  • One (1) x 100Mbps for IPMI

Prerequisites

Before you get out to your data center and start powering things up make sure you have the following things available:

  • The first and one of the most important requirements is to have two (2) 10GE cables connected to each node, the installation process will not complete the verify process until both cables are connected and enabled. See error bellow.

  • VxRail: hostname and IP address
  • VxRail and vCenter password
  • ESXi hostnames: you are going to need at least four names
  • ESXi host IPs: four management IP addresses for the ESXi management
  • ESXi password: password to be used to configure ESXi
  • vMotion: four vMotion IPs
  • vSAN: four IPs to create the vSAN cluster
  • vCenter: name and IP for the vCenter virtual appliance
  • vCenter Password
  • vRealize Logging: One IP address for the login server
  • VxRail Manager Expansion: One IP Address
  • Two power outlets to connect the two power supplies
  • Four 1GE cables and ports for IPMI
  • Four IPMI IP addresses

Installation Procedure

After connecting the two power supplies and the 8 SFP+ / Twinax cables, turn on the servers in the following order Node1, Node2, Node3 and Node4. Wait about 10 minutes to have all components enabled.

Open a web browser an point it to the default IP 192.168.10.200, you might need to manually setup your machine’s IP Address to an IP address like 192.168.10.199. If you are using Mac, Safari will not completely work, this has been the case since the original EVO:Rail came out, so you will need to install Firefox or Chrome.

During the next steps you will fill out the different fields with the information collected during the Prerequisites phase.

The initial screen is the Welcome screen where you will click continue to start the installation and configuration.

The first real configuration screen will have you defining Hostnames, IP Address and passwords.

Configure the NTP server. You need to have a valid and reachable server otherwise the validation process will fail and you won’t be able to complete the installation.

Following screen is to configure the vMotion network

The it is the turn to configure vSAN

Add Virtual Networks

Configure Logging solutions

Finally, verify the parameters you added to the configurator

Once the validation is complete and completely free of errors you can commit the configuration. The process will update the host names, host IP addresses, update the management IP, deploy vCenter (appliance), configure VSAN, the virtual switches. At the end of the process you will receive a “Hooray” message, letting you know that you are ready to start creating VMs.hooray-message

Please visit us again for part two of this series where we will show you the management interface and other features of VxRail.

—-update 3/10/2016—-

I have also created a video that shows the installation process. Click on this link to watch the video

Thank you for reading.

25 Replies to “VxRail First Impressions, Installation, Configuration (part 1)”

  1. Pingback: Installing VxRail Video -

  2. Pingback: Newsletter: March 11, 2016 | Notes from MWhite

    • Thank you for letting me know Kenneth, I clicked on the link and it definitely looks the same but when I click on the link it redirects the page to this post so I think it is ok. Do you experience the same behavior?

  3. Hi, first of all thank you for sharing. We want to initialize a VxRail 120, the 4 nodes are connected to a Nexus SW VLAN 100 and also our lap does, but we can’t ping or open the default IP address in a web browser. Could you please give us what should be the logical and physical configuration in the nexus switch? Is need it a special configuration?

    As an additional information we power on the nodes from 4 to 1, Dou you think this matters?

    Thanks in advanced

    • Hi. This makes sense. The temporary ip may not reach your machine as it is different network. Did you managed to fix it? Did you worked with flat network switch? What is the work around?

      • Hello Carlos and Swapnil, as you know when you first turn on your VxRail appliance it is configured on the 192.168.10.x network and that traffic is “untagged”. The first step is to give yourself a manual IP, I always use 192.168.10.199. If you have a flat network/test unmanaged switch then that should be it, you can configure the rest of the IPs on the same network for example, 10.10.10.x. If you are using a manage switch with multiple VLANs the first thing to do is to setup up 9 ports in trunk mode, each port will have all the VLANs you need and you must define a “native VLAN”. The initial configuration goes over 192.168.10.x, which is untagged and because you declared a native vlan, all untagged traffic will default to that native VLAN making that conversation basically a layer 2 conversation. I can stress how important is defining that Native VLAN for this process to work. I have seen customers struggling with the setup and as soon as we do this all problems are fixed. I have a new blog post coming up with VxRail 3.5 where I will go over this in detail.

    • Carlos, make sure you have setup the switchport you’re connected to the laptop in access mode, that port might be still in default trunk mode.

  4. Hi Eduardo,

    thanks for the fantastic post!

    Just a quick question. To which port on the VxRail nodes you connect your laptop, to the Management port of node 1?

    Or you connect your laptop to the data port of node 1?

    Thanks.

    SANTS boy

    • Hello, sorry for my very delayed response. You actually have to connect your laptop to a ninth port that belongs to the same port groups as the 8 ports the VxRails is connected. That way you can set your laptop to manual IP and dp the initial configuration. I have an SFP+ to RJ45 adapter so I can actually plug right into the same switch the VxRail is plugged into

  5. Is the power on sequence 1, 2, 3 and 4 or is it 4, 3 2 and 1.

    Can you please confirm. Thanks in advance

    I see in EMC procedure generator it is the other way

    Power up one node at a time in the following sequence:

    a. Node 4
    b. Node 3
    c. Node 2
    d. Node 1

    • I have tried both ways and honestly haven’t found a difference but I do power on one node at a time with a minute or two in between nodes

    • You need to startup node1 first, because it contains the essential vms for proper operation (vcenter, psc, vxrail manager, vrealize log)

  6. Hi,

    Could you please see the below error ??

    Validation will take a few minutes. Please wait patiently, and do not move between pages in the user interface.
    The host with identifier: QCFVR163233001-04-01 has an unrecognized physical network configuration.
    The host with identifier: QCFVR163233001-04-02 has an unrecognized physical network configuration.
    The host with identifier: QCFVR163233001-04-03 has an unrecognized physical network configuration.
    The host with identifier: QCFVR163233001-04-04 has an unrecognized physical network configuration.

    • Hello Jamshed, I have actually seen that error before. The time I saw the error, it was related to the speed and configuration of the ports the server is connected to. VxRail needs at least 10Gbps NICs connected to pass the configuration test.

      what is the configuration you are using on those ports?

  7. Good writeup. I’m actually in the process of deploying one of these myself. I got a used unit to use as a lab. As it turns out, the unit has the fans missing and I can’t seem to find them to save my life.

    Do you by any-chance have any documentation as to what the PN for the fans may be? Or perhaps you have pictures of the fans themselves?

    Anything would be helpful.

    Thanks.

  8. Hi Eduardo,

    Thanks for sharing this, to make management Vlan (ESXI Host IP, Vcenter, VXrail Manager, logs manager) to vlan other than default (i.e 0) such as 1000 what will be required at network end. Currently we have trunk the interface as it carries multiple VLAN. I was reading in some article we have to ensure that native vlan of that trunk interface should be 1000 inorder to access these services please confirm

      • @eduardo Hi guys i can not reach the evo rail of my vxrail.. i have a flat switch and cant even ping the 10.200 which is the default ip. And when i go into all my nodes it shows unknown (inaccesible) vms.. what m i doin wrong? I have give all the nodes are on a .10 subnet

  9. Hi guys i can not reach the evo rail of my vxrail.. i have a flat switch and cant even ping the 10.200 which is the default ip. And when i go into all my nodes it shows unknown (inaccesible) vms.. what m i doin wrong? I have give all the nodes are on a .10 subnet

Leave a Reply to Tanya Cancel reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>